PyPI/tensorflow CVE-2020-26271: medium 4.4, EPSS 0.22%
Heap out of bounds access in MakeEdge in TensorFlow
Action: Upgrade tensorflow to 1.15.5 or later.
pip install tensorflow==1.15.5pip install tensorflow==2.0.4pip install tensorflow==2.1.3pip install tensorflow==2.2.2pip install tensorflow==2.3.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.5 | - |
| 2.0.0 | 2.0.4 | - |
| 2.1.0 | 2.1.3 | - |
| 2.2.0 | 2.2.2 | - |
| 2.3.0 | 2.3.2 | - |
Fixed versions
| 1.15.5 | 2.0.4 | 2.1.3 | 2.2.2 | 2.3.2 |
Sources
- osv: GHSA-q263-fvxm-m5mw
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-q263-fvxm-m5mw
- https://nvd.nist.gov/vuln/detail/CVE-2020-26271
- https://github.com/tensorflow/tensorflow/commit/0cc38aaa4064fd9e79101994ce9872c6d91f816b
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-302.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-337.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-257.yaml
CVE-2020-26271 · published · modified · JSON