PyPI/pillow CVE-2021-28677: high 7.5, EPSS 2.47%
Uncontrolled Resource Consumption in Pillow
Action: Upgrade pillow to 8.2.0 or later.
pip install pillow==8.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 8.2.0 | - |
Fixed versions
| 8.2.0 |
Sources
- osv: GHSA-q5hq-fp76-qmrc
- https://nvd.nist.gov/vuln/detail/CVE-2021-28677
- https://github.com/python-pillow/Pillow/pull/5377
- https://github.com/python-pillow/Pillow/commit/5a5e6db0abf4e7a638fb1b3408c4e495a096cb92
- https://github.com/advisories/GHSA-q5hq-fp76-qmrc
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2021-93.yaml
- https://github.com/python-pillow/Pillow
- https://lists.debian.org/debian-lts-announce/2021/07/msg00018.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/MQHA5HAIBOYI3R6HDWCLAGFTIQP767FL
- https://pillow.readthedocs.io/en/stable/releasenotes/8.2.0.html#cve-2021-28677-fix-eps-dos-on-open
- https://security.gentoo.org/glsa/202107-33
CVE-2021-28677 · published · modified · JSON