PyPI/slixmpp CVE-2022-45197: high 7.5, EPSS 0.51%
Slixmpp lacks SSL Certificate hostname validation in XMLStream
Action: Upgrade slixmpp to 1.8.3 or later.
pip install slixmpp==1.8.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.8.3 | - |
Fixed versions
| 1.8.3 |
Sources
- osv: GHSA-q6cq-m9gm-6q2f
- https://nvd.nist.gov/vuln/detail/CVE-2022-45197
- https://github.com/poezio/slixmpp
- https://github.com/poezio/slixmpp/commits/master/slixmpp/xmlstream/xmlstream.py
- https://github.com/poezio/slixmpp/tags
- https://github.com/pypa/advisory-database/tree/main/vulns/slixmpp/PYSEC-2022-43013.yaml
- https://lab.louiz.org/poezio/slixmpp/-/commit/b60b1b985db928532f97c4f61d6fbc801f0aa7fa
- https://lab.louiz.org/poezio/slixmpp/-/commits/master
- https://security.gentoo.org/glsa/202305-07
CVE-2022-45197 · published · modified · JSON