PyPI/octavia CVE-2018-16856: high 7.5, EPSS 0.89%
Openstack Octavia allows Insertion of Sensitive Information into Log File
Action: Upgrade octavia to 2.1.0 or later.
pip install octavia==2.1.0pip install octavia==3.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.0 | - |
| 3.0.0.0b1 | 3.1.0 | - |
Fixed versions
| 2.1.0 | 3.1.0 |
Sources
- osv: GHSA-qcj3-h27m-mp9x
- https://nvd.nist.gov/vuln/detail/CVE-2018-16856
- https://github.com/openstack/octavia/commit/ae7c87f54a6c5483a608d5e9fe51ea1966ea1f7e
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-16856
- https://github.com/openstack/octavia
- https://github.com/openstack/octavia/commits/3.1.0
- https://github.com/pypa/advisory-database/tree/main/vulns/octavia/PYSEC-2019-193.yaml
CVE-2018-16856 · published · modified · JSON