PyPI/pysaml2 CVE-2020-5390: high 7.5, EPSS 1.23%
Improper Verification of Cryptographic Signature in PySAML2
Action: Upgrade pysaml2 to 5.0.0 or later.
pip install pysaml2==5.0.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 5.0.0 | - |
Fixed versions
| 5.0.0 |
Sources
- osv: GHSA-qf7v-8hj3-4xw7
- https://nvd.nist.gov/vuln/detail/CVE-2020-5390
- https://github.com/IdentityPython/pysaml2/commit/5e9d5acbcd8ae45c4e736ac521fd2df5b1c62e25
- https://github.com/IdentityPython/pysaml2/commit/f27c7e7a7010f83380566a219fd6a290a00f2b6e
- https://github.com/IdentityPython/pysaml2
- https://github.com/IdentityPython/pysaml2/blob/master/CHANGELOG.md#500-2020-01-13
- https://github.com/IdentityPython/pysaml2/releases
- https://github.com/IdentityPython/pysaml2/releases/tag/v5.0.0
- https://github.com/advisories/GHSA-qf7v-8hj3-4xw7
- https://github.com/pypa/advisory-database/tree/main/vulns/pysaml2/PYSEC-2020-94.yaml
- https://lists.debian.org/debian-lts-announce/2020/02/msg00025.html
- https://pypi.org/project/pysaml2/5.0.0
- https://usn.ubuntu.com/4245-1
- https://www.debian.org/security/2020/dsa-4630
CVE-2020-5390 · published · modified · JSON