PyPI/swauth CVE-2017-16613: critical 9.8, EPSS 8.42%
OpenStack Swauth object/proxy server writing Auth Token to log file
Action: Upgrade swauth to 1.3.0 or later.
pip install swauth==1.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.3.0 | - |
Fixed versions
| 1.3.0 |
Sources
- osv: GHSA-qhq8-xwqv-pvv9
- https://nvd.nist.gov/vuln/detail/CVE-2017-16613
- https://github.com/openstack/swauth/commit/70af7986265a3defea054c46efc82d0698917298
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=882314
- https://bugs.launchpad.net/swift/+bug/1655781
- https://github.com/openstack/swauth
- https://github.com/pypa/advisory-database/tree/main/vulns/swauth/PYSEC-2017-84.yaml
- https://web.archive.org/web/20200227140059/http://www.securityfocus.com/bid/101926
- https://www.debian.org/security/2017/dsa-4044
CVE-2017-16613 · published · modified · JSON