PyPI/transformers CVE-2025-2099: medium 5.3, EPSS 0.61%
Hugging Face Transformers Regular Expression Denial of Service
Action: Upgrade transformers to 4.50.0 or later.
pip install transformers==4.50.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.50.0 | - |
Fixed versions
| 4.50.0 |
Sources
- osv: GHSA-qq3j-4f4f-9583
- https://nvd.nist.gov/vuln/detail/CVE-2025-2099
- https://github.com/huggingface/transformers/pull/36648
- https://github.com/huggingface/transformers/commit/8cb522b4190bd556ce51be04942720650b1a3e57
- https://github.com/huggingface/transformers
- https://github.com/pypa/advisory-database/tree/main/vulns/transformers/PYSEC-2025-40.yaml
- https://huntr.com/bounties/97b780f3-ffca-424f-ad5d-0e1c57a5bde4
CVE-2025-2099 · published · modified · JSON