tocsin

PyPI/lightning CVE-2026-58659: high 7.8, EPSS 0.63%

PyTorch Lightning allows arbitrary code execution through checkpoint _instantiator hyperparameters

Action: Upgrade lightning to 2.6.6 or later.

pip install lightning==2.6.6

Affected

introducedfixedlast affected
02.6.6-

Fixed versions

2.6.6

Sources

CVE-2026-58659 · published · modified · JSON