PyPI/dnslib CVE-2022-22846: high 7.5, EPSS 0.84%
dnslib has DNS reply verification issue
Action: Upgrade dnslib to 0.9.17 or later.
pip install dnslib==0.9.17Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.9.17 | - |
Fixed versions
| 0.9.17 |
Sources
- osv: GHSA-r478-c2pc-m7gx
- https://nvd.nist.gov/vuln/detail/CVE-2022-22846
- https://github.com/paulc/dnslib/issues/30
- https://github.com/paulc/dnslib/commit/76e8677699ed098387d502c57980f58da642aeba
- https://github.com/advisories/GHSA-r478-c2pc-m7gx
- https://github.com/paulc/dnslib
- https://github.com/pypa/advisory-database/tree/main/vulns/dnslib/PYSEC-2022-4.yaml
CVE-2022-22846 · published · modified · JSON