PyPI/tensorflow CVE-2021-41224: high 7.1, EPSS 0.21%
`SparseFillEmptyRows` heap OOB
Action: Upgrade tensorflow to 2.4.4 or later.
pip install tensorflow==2.6.1pip install tensorflow==2.5.2pip install tensorflow==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-rg3m-hqc5-344v
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rg3m-hqc5-344v
- https://nvd.nist.gov/vuln/detail/CVE-2021-41224
- https://github.com/tensorflow/tensorflow/commit/67bfd9feeecfb3c61d80f0e46d89c170fbee682b
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-633.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-831.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-416.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41224 · published · modified · JSON