PyPI/vllm CVE-2025-24357: high 7.5, EPSS 0.89%
vllm: Malicious model to RCE by torch.load in hf_model_weights_iterator
Action: Upgrade vllm to 0.7.0 or later.
pip install vllm==0.7.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.0 | - |
Fixed versions
| 0.7.0 |
Sources
- osv: GHSA-rh4j-5rhw-hr54
- https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54
- https://nvd.nist.gov/vuln/detail/CVE-2025-24357
- https://github.com/vllm-project/vllm/pull/12366
- https://github.com/vllm-project/vllm/commit/d3d6bb13fb62da3234addf6574922a4ec0513d04
- https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-58.yaml
- https://github.com/vllm-project/vllm
- https://github.com/vllm-project/vllm/releases/tag/v0.7.0
- https://pytorch.org/docs/stable/generated/torch.load.html
CVE-2025-24357 · published · modified · JSON