PyPI/tensorflow CVE-2022-36015: low, EPSS 0.70%
TensorFlow vulnerable to integer overflow in math ops
Action: Upgrade tensorflow to 2.7.2 or later.
pip install tensorflow==2.7.2pip install tensorflow==2.8.1pip install tensorflow==2.9.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
| 2.8.0 | 2.8.1 | - |
| 2.9.0 | 2.9.1 | - |
Fixed versions
| 2.7.2 | 2.8.1 | 2.9.1 |
Sources
- osv: GHSA-rh87-q4vg-m45j
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rh87-q4vg-m45j
- https://nvd.nist.gov/vuln/detail/CVE-2022-36015
- https://github.com/tensorflow/tensorflow/commit/37e64539cd29fcfb814c4451152a60f5d107b0f0
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/ops/math_ops.cc
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0
CVE-2022-36015 · published · modified · JSON