tocsin

PyPI/vllm CVE-2025-25183: low 2.6, EPSS 0.19%

vLLM uses Python 3.12 built-in hash() which leads to predictable hash collisions in prefix cache

Action: Upgrade vllm to 0.7.2 or later.

pip install vllm==0.7.2

Affected

introducedfixedlast affected
00.7.2-

Fixed versions

0.7.2

Sources

CVE-2025-25183 · published · modified · JSON