PyPI/tensorflow-cpu CVE-2020-15265: medium 5.9, EPSS 0.91%
Segfault in `tf.quantization.quantize_and_dequantize`
Action: Upgrade tensorflow-cpu to 2.4.0 or later.
pip install tensorflow-cpu==2.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.4.0 | - |
Fixed versions
| 2.4.0 |
Sources
- osv: GHSA-rrfp-j2mp-hq9c#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rrfp-j2mp-hq9c
- https://nvd.nist.gov/vuln/detail/CVE-2020-15265
- https://github.com/tensorflow/tensorflow/issues/42105
- https://github.com/tensorflow/tensorflow/commit/eccb7ec454e6617738554a255d77f08e60ee0808
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-295.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-330.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-138.yaml
- https://github.com/tensorflow/tensorflow
CVE-2020-15265 · published · modified · JSON