PyPI/langflow CVE-2025-3248: critical 9.8, exploited, EPSS 99.99%
Langflow Unauth RCE
Action: Upgrade langflow to 1.3.0 or later.
pip install langflow==1.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.3.0 | - |
Fixed versions
| 1.3.0 |
Sources
- osv: GHSA-rvqx-wpfh-mfx7
- kev: CVE-2025-3248
- nvd: CVE-2025-3248
- https://github.com/langflow-ai/langflow/security/advisories/GHSA-rvqx-wpfh-mfx7
- https://github.com/langflow-ai/langflow/pull/6911
- https://github.com/langflow-ai/langflow/commit/faac4db133de32fcb6d483fa9ff52f40ce42bdc0
- https://github.com/langflow-ai/langflow
- https://github.com/langflow-ai/langflow/releases/tag/1.3.0
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-3248
- https://www.horizon3.ai/attack-research/disclosures/unsafe-at-any-speed-abusing-python-exec-for-unauth-rce-in-langflow-ai
- https://www.vulncheck.com/advisories/langflow-unauthenticated-rce
- https://github.com/pypa/advisory-database/tree/main/vulns/langflow-base/PYSEC-2026-380.yaml
- https://pypi.org/project/langflow-base
CVE-2025-3248 · published · modified · JSON