PyPI/gitpython CVE-2026-67324: critical 9.8, EPSS 0.45%
GitPython unsafe clone option gate bypass through joined short options
Action: Upgrade gitpython to 3.1.51 or later.
pip install gitpython==3.1.51Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.1.50 | 3.1.51 | - |
Fixed versions
| 3.1.51 |
Sources
- osv: GHSA-v396-v7q4-x2qj
- nvd: CVE-2026-67324
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-v396-v7q4-x2qj
- https://github.com/gitpython-developers/GitPython/pull/2162
- https://github.com/gitpython-developers/GitPython
- https://github.com/gitpython-developers/GitPython/releases/tag/3.1.51
CVE-2026-67324 · published · modified · JSON