PyPI/gitpython CVE-2026-44244: high 7.8, EPSS 0.24%
GitPython: Newline injection in config_writer().set_value() enables RCE via core.hooksPath
Action: Upgrade gitpython to 3.1.49 or later.
pip install gitpython==3.1.49Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.1.49 | - |
Fixed versions
| 3.1.49 |
Sources
- osv: GHSA-v87r-6q3f-2j67
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-v87r-6q3f-2j67
- https://nvd.nist.gov/vuln/detail/CVE-2026-44244
- https://github.com/gitpython-developers/GitPython
- https://github.com/gitpython-developers/GitPython/releases/tag/3.1.49
CVE-2026-44244 · published · modified · JSON