PyPI/openssl-encrypt CVE-2026-74874: high 7.5, EPSS 0.44%
openssl-encrypt has non-cryptographic PRNG used for steganography pixel selection
Action: Upgrade openssl-encrypt to 1.4.0 or later.
pip install openssl-encrypt==1.4.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.0 | - |
Fixed versions
| 1.4.0 |
Sources
- osv: GHSA-vfgx-5q85-58q3
- nvd: CVE-2026-74874
- https://github.com/jahlives/openssl_encrypt/security/advisories/GHSA-vfgx-5q85-58q3
- https://github.com/jahlives/openssl_encrypt/commit/09e96e090417d34d2f533f6810d3cd4f77810101
- https://github.com/jahlives/openssl_encrypt
CVE-2026-74874 · published · modified · JSON