tocsin

PyPI/pymatgen CVE-2024-23346: critical 9.3, EPSS 3.85%

pymatgen vulnerable to arbitrary code execution when parsing a maliciously crafted JonesFaithfulTransformation transformation_string

Action: Upgrade pymatgen to 2024.2.20 or later.

pip install pymatgen==2024.2.20

Affected

introducedfixedlast affected
02024.2.20-

Fixed versions

2024.2.20

Sources

CVE-2024-23346 · published · modified · JSON