PyPI/pillow CVE-2026-59204: high 7.5, EPSS 0.39%
Pillow JPEG2000 tiled decode retains a growing scratch buffer and can be used for denial of service
Action: Upgrade pillow to 12.3.0 or later.
pip install pillow==12.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 8.2.0 | 12.3.0 | - |
Fixed versions
| 12.3.0 |
Sources
- osv: GHSA-vjc4-5qp5-m44j
- nvd: CVE-2026-59204
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-vjc4-5qp5-m44j
- https://github.com/python-pillow/Pillow/pull/9704
- https://github.com/python-pillow/Pillow/commit/13ada41172142f2fd9f0906f615a00ea623a11ca
- https://github.com/python-pillow/Pillow
- https://github.com/python-pillow/Pillow/releases/tag/12.3.0
CVE-2026-59204 · published · modified · JSON