PyPI/pglast CVE-2018-18482: medium 6.5, EPSS 1.16%
libpg_query memory leak
Action: Upgrade pglast to 0.28 or later.
pip install pglast==0.28Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.28 | - |
Fixed versions
| 0.28 |
Sources
- osv: GHSA-vm3q-58wm-2r2x#PyPI/pglast
- https://nvd.nist.gov/vuln/detail/CVE-2018-18482
- https://github.com/lfittl/libpg_query/issues/49
- https://github.com/lelit/pglast
- https://github.com/pypa/advisory-database/tree/main/vulns/pg-query/PYSEC-2018-154.yaml
CVE-2018-18482 · published · modified · JSON