PyPI/tensorflow-cpu CVE-2021-37669: medium 5.5, EPSS 0.18%
Crash in NMS ops caused by integer conversion to unsigned
Action: Upgrade tensorflow-cpu to 2.3.4 or later.
pip install tensorflow-cpu==2.3.4pip install tensorflow-cpu==2.4.3pip install tensorflow-cpu==2.5.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.3.4 | - |
| 2.4.0 | 2.4.3 | - |
| 2.5.0 | 2.5.1 | - |
Fixed versions
| 2.3.4 | 2.4.3 | 2.5.1 |
Sources
- osv: GHSA-vmjw-c2vp-p33c#PyPI/tensorflow-cpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vmjw-c2vp-p33c
- https://nvd.nist.gov/vuln/detail/CVE-2021-37669
- https://github.com/tensorflow/tensorflow/commit/3a7362750d5c372420aa8f0caf7bf5b5c3d0f52d
- https://github.com/tensorflow/tensorflow/commit/b5cdbf12ffcaaffecf98f22a6be5a64bb96e4f58
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-582.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-780.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-291.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-37669 · published · modified · JSON