PyPI/tensorflow-gpu CVE-2021-41214: high 7.8, EPSS 0.22%
Reference binding to `nullptr` in `tf.ragged.cross`
Action: Upgrade tensorflow-gpu to 2.4.4 or later.
pip install tensorflow-gpu==2.6.1pip install tensorflow-gpu==2.5.2pip install tensorflow-gpu==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.6.0 | 2.6.1 | - |
| 2.5.0 | 2.5.2 | - |
| 0 | 2.4.4 | - |
Fixed versions
| 2.6.1 | 2.5.2 | 2.4.4 |
Sources
- osv: GHSA-vwhq-49r4-gj9v#PyPI/tensorflow-gpu
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vwhq-49r4-gj9v
- https://nvd.nist.gov/vuln/detail/CVE-2021-41214
- https://github.com/tensorflow/tensorflow/commit/fa6b7782fbb14aa08d767bc799c531f5e1fb3bb8
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-623.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-821.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-406.yaml
- https://github.com/tensorflow/tensorflow
CVE-2021-41214 · published · modified · JSON