PyPI/aiohttp CVE-2026-22815: high 7.5, EPSS 0.46%
aiohttp allows unlimited trailer headers, leading to possible uncapped memory usage
Action: Upgrade aiohttp to 3.13.4 or later.
pip install aiohttp==3.13.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.13.4 | - |
Fixed versions
| 3.13.4 |
Sources
- osv: GHSA-w2fm-2cpv-w7v5
- nvd: CVE-2026-22815
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-w2fm-2cpv-w7v5
- https://github.com/aio-libs/aiohttp/commit/0c2e9da51126238a421568eb7c5b53e5b5d17b36
- https://github.com/aio-libs/aiohttp
- https://github.com/aio-libs/aiohttp/releases/tag/v3.13.4
CVE-2026-22815 · published · modified · JSON