tocsin

PyPI/jupyter-server-proxy CVE-2024-28179: critical 9, EPSS 1.03%

Jupyter Server Proxy's Websocket Proxying does not require authentication

Action: Upgrade jupyter-server-proxy to 3.2.3 or later.

pip install jupyter-server-proxy==4.1.1
pip install jupyter-server-proxy==3.2.3

Affected

introducedfixedlast affected
4.0.04.1.1-
03.2.3-

Fixed versions

4.1.13.2.3

Sources

CVE-2024-28179 · published · modified · JSON