PyPI/ray CVE-2025-1979: medium 6.4, EPSS 0.20%
ray vulnerable to Insertion of Sensitive Information into Log File
Action: Upgrade ray to 2.43.0 or later.
pip install ray==2.43.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.43.0 | - |
Fixed versions
| 2.43.0 |
Sources
- osv: GHSA-w4rh-fgx7-q63m
- https://nvd.nist.gov/vuln/detail/CVE-2025-1979
- https://github.com/ray-project/ray/issues/50266
- https://github.com/ray-project/ray/pull/50409
- https://github.com/ray-project/ray/commit/64a2e4010522d60b90c389634f24df77b603d85d
- https://github.com/pypa/advisory-database/tree/main/vulns/ray/PYSEC-2025-23.yaml
- https://github.com/ray-project/ray
- https://security.snyk.io/vuln/SNYK-PYTHON-RAY-8745212
CVE-2025-1979 · published · modified · JSON