PyPI/praisonai CVE-2026-57117: high 8.8, EPSS 0.58%
PraisonAI: Compute-bridged file tools allow shell command injection
Action: Upgrade praisonai to 4.6.59 or later.
pip install praisonai==4.6.59Affected
| introduced | fixed | last affected |
|---|---|---|
| 4.6.10 | 4.6.59 | - |
Fixed versions
| 4.6.59 |
Sources
- osv: GHSA-w6h2-fr4q-xvxv
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-w6h2-fr4q-xvxv
- https://github.com/MervinPraison/PraisonAI
CVE-2026-57117 · published · modified · JSON