PyPI/mlx CVE-2025-62608: critical 9.1, EPSS 0.56%
MLX has heap-buffer-overflow in load()
Action: Upgrade mlx to 0.29.4 or later.
pip install mlx==0.29.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.29.4 | - |
Fixed versions
| 0.29.4 |
Sources
- osv: GHSA-w6vg-jg77-2qg6
- nvd: CVE-2025-62608
- https://github.com/ml-explore/mlx/security/advisories/GHSA-w6vg-jg77-2qg6
- https://github.com/ml-explore/mlx/pull/1
- https://github.com/ml-explore/mlx/pull/2
- https://github.com/ml-explore/mlx
- https://github.com/pypa/advisory-database/tree/main/vulns/mlx/PYSEC-2025-138.yaml
CVE-2025-62608 · published · modified · JSON