PyPI/cryptography CVE-2023-23931: medium 6.5, EPSS 1.30%
Cipher.update_into can corrupt memory if passed an immutable python object as the outbuf
Action: Upgrade cryptography to 39.0.1 or later.
pip install cryptography==39.0.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 1.8 | 39.0.1 | - |
Fixed versions
| 39.0.1 |
Sources
- osv: GHSA-w7pp-m8wf-vj6r
- https://github.com/pyca/cryptography/security/advisories/GHSA-w7pp-m8wf-vj6r
- https://nvd.nist.gov/vuln/detail/CVE-2023-23931
- https://github.com/pyca/cryptography/pull/8230
- https://github.com/pyca/cryptography/commit/d6951dca25de45abd52da51b608055371fbcde4e
- https://github.com/pyca/cryptography
- https://github.com/pypa/advisory-database/tree/main/vulns/cryptography/PYSEC-2023-11.yaml
- https://lists.debian.org/debian-lts-announce/2024/10/msg00012.html
- https://security.netapp.com/advisory/ntap-20230324-0007
CVE-2023-23931 · published · modified · JSON