PyPI/datasette CVE-2025-64481: low 2.7, EPSS 0.41%
Open redirect endpoint in Datasette
Action: Upgrade datasette to 0.65.2 or later.
pip install datasette==0.65.2pip install datasette==1.0a21Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.65.2 | - |
| 1.0a0 | 1.0a21 | - |
Fixed versions
| 0.65.2 | 1.0a21 |
Sources
- osv: GHSA-w832-gg5g-x44m
- nvd: CVE-2025-64481
- https://github.com/simonw/datasette/security/advisories/GHSA-w832-gg5g-x44m
- https://github.com/simonw/datasette/issues/2429
- https://github.com/simonw/datasette/commit/f257ca6edb64848c3b04b54d41e347c54fe57c05
- https://github.com/pypa/advisory-database/tree/main/vulns/datasette/PYSEC-2025-73.yaml
- https://github.com/simonw/datasette
CVE-2025-64481 · published · modified · JSON