PyPI/tensorflow CVE-2022-23563: high 7.1, EPSS 0.11%
Insecure temporary file in Tensorflow
Action: Upgrade tensorflow to 2.5.3 or later.
pip install tensorflow==2.5.3pip install tensorflow==2.6.3pip install tensorflow==2.7.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.5.3 | - |
| 2.6.0 | 2.6.3 | - |
| 2.7.0 | 2.7.1 | - |
Fixed versions
| 2.5.3 | 2.6.3 | 2.7.1 |
Sources
- osv: GHSA-wc4g-r73w-x8mm
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wc4g-r73w-x8mm
- https://nvd.nist.gov/vuln/detail/CVE-2022-23563
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-72.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-127.yaml
- https://github.com/tensorflow/tensorflow
CVE-2022-23563 · published · modified · JSON