PyPI/pillow CVE-2026-40192: high 7.5, EPSS 0.67%
FITS GZIP decompression bomb in Pillow
Action: Upgrade pillow to 12.2.0 or later.
pip install pillow==12.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 10.3.0 | 12.2.0 | - |
Fixed versions
| 12.2.0 |
Sources
- osv: GHSA-whj4-6x5x-4v2j
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-whj4-6x5x-4v2j
- https://nvd.nist.gov/vuln/detail/CVE-2026-40192
- https://github.com/python-pillow/Pillow/pull/9521
- https://github.com/python-pillow/Pillow/commit/3cb854e8b2bab43f40e342e665f9340d861aa628
- https://github.com/python-pillow/Pillow
- https://pillow.readthedocs.io/en/stable/releasenotes/12.2.0.html#prevent-fits-decompression-bomb
CVE-2026-40192 · published · modified · JSON