PyPI/pillow CVE-2026-42308: medium 5.5, EPSS 0.11%
Pillow has an integer overflow when processing fonts
Action: Upgrade pillow to 12.2.0 or later.
pip install pillow==12.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 12.2.0 | - |
Fixed versions
| 12.2.0 |
Sources
- osv: GHSA-wjx4-4jcj-g98j
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-wjx4-4jcj-g98j
- https://nvd.nist.gov/vuln/detail/CVE-2026-42308
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2026-165.yaml
- https://github.com/python-pillow/Pillow
- https://github.com/python-pillow/Pillow/releases/tag/12.2.0
CVE-2026-42308 · published · modified · JSON