PyPI/tensorflow CVE-2022-35993: medium 5.9, EPSS 0.48%
TensorFlow vulnerable to `CHECK` fail in `SetSize`
Action: Upgrade tensorflow to 2.7.2 or later.
pip install tensorflow==2.7.2pip install tensorflow==2.8.1pip install tensorflow==2.9.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.2 | - |
| 2.8.0 | 2.8.1 | - |
| 2.9.0 | 2.9.1 | - |
Fixed versions
| 2.7.2 | 2.8.1 | 2.9.1 |
Sources
- osv: GHSA-wq6q-6m32-9rv9
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-wq6q-6m32-9rv9
- https://nvd.nist.gov/vuln/detail/CVE-2022-35993
- https://github.com/tensorflow/tensorflow/commit/cf70b79d2662c0d3c6af74583641e345fc939467
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0
CVE-2022-35993 · published · modified · JSON