tocsin

PyPI/mechanicalsoup CVE-2023-34457: medium 5.9, EPSS 1.08%

MechanicalSoup vulnerable to malicious web server reading arbitrary files on client using file input inside HTML form

Action: Upgrade mechanicalsoup to 1.3.0 or later.

pip install mechanicalsoup==1.3.0

Affected

introducedfixedlast affected
0.2.01.3.0-

Fixed versions

1.3.0

Sources

CVE-2023-34457 · published · modified · JSON