PyPI/pypdf CVE-2026-27888: high 7.5, EPSS 0.40%
pypdf: Manipulated FlateDecode XFA streams can exhaust RAM
Action: Upgrade pypdf to 6.7.3 or later.
pip install pypdf==6.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 6.7.3 | - |
Fixed versions
| 6.7.3 |
Sources
- osv: GHSA-x7hp-r3qg-r3cj
- nvd: CVE-2026-27888
- https://github.com/py-pdf/pypdf/security/advisories/GHSA-x7hp-r3qg-r3cj
- https://github.com/py-pdf/pypdf/pull/3658
- https://github.com/py-pdf/pypdf/commit/7a4c8246ed48d9d328fb596942271da47b6d109c
- https://github.com/py-pdf/pypdf
- https://github.com/py-pdf/pypdf/releases/tag/6.7.3
CVE-2026-27888 · published · modified · JSON