PyPI/tensorflow CVE-2020-15210: medium 6.5, EPSS 0.74%
Segmentation fault in tensorflow-lite
Action: Upgrade tensorflow to 1.15.4 or later.
pip install tensorflow==1.15.4pip install tensorflow==2.0.3pip install tensorflow==2.1.2pip install tensorflow==2.2.1pip install tensorflow==2.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.15.4 | - |
| 2.0.0 | 2.0.3 | - |
| 2.1.0 | 2.1.2 | - |
| 2.2.0 | 2.2.1 | - |
| 2.3.0 | 2.3.1 | - |
Fixed versions
| 1.15.4 | 2.0.3 | 2.1.2 | 2.2.1 | 2.3.1 |
Sources
- osv: GHSA-x9j7-x98r-r4w2
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2
- https://nvd.nist.gov/vuln/detail/CVE-2020-15210
- https://github.com/tensorflow/tensorflow/commit/094329d0dcb8290bed2b1ee420934971f422c86d
- https://github.com/tensorflow/tensorflow/commit/1c8709b437fec10875b0cf271889afec9bbf582e
- https://github.com/tensorflow/tensorflow/commit/8c2092e9f9ef78b3f9060f8bf5ce7a49d1ccdc8f
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453
- https://github.com/tensorflow/tensorflow/commit/f4159ccef23d11eb58ee4263beaaeac1be3343c7
- https://github.com/tensorflow/tensorflow/commit/f50a14b00560a383865c2273e4a9094add3888d5
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-290.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-325.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-133.yaml
- https://github.com/tensorflow/tensorflow
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
CVE-2020-15210 · published · modified · JSON