PyPI/pillow CVE-2025-48379: high 7.1, EPSS 0.33%
Pillow vulnerability can cause write buffer overflow on BCn encoding
Action: Upgrade pillow to 11.3.0 or later.
pip install pillow==11.3.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 11.2.0 | 11.3.0 | - |
Fixed versions
| 11.3.0 |
Sources
- osv: GHSA-xg8h-j46f-w952
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-xg8h-j46f-w952
- https://nvd.nist.gov/vuln/detail/CVE-2025-48379
- https://github.com/python-pillow/Pillow/pull/9041
- https://github.com/python-pillow/Pillow/commit/ef98b3510e3e4f14b547762764813d7e5ca3c5a4
- https://github.com/pypa/advisory-database/tree/main/vulns/pillow/PYSEC-2025-61.yaml
- https://github.com/python-pillow/Pillow
- https://github.com/python-pillow/Pillow/releases/tag/11.3.0
CVE-2025-48379 · published · modified · JSON