PyPI/httpie CVE-2019-10751: high 8.8, EPSS 2.04%
Open Redirect in httpie
Action: Upgrade httpie to 1.0.3 or later.
pip install httpie==1.0.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.0.3 | - |
Fixed versions
| 1.0.3 |
Sources
- osv: GHSA-xjjg-vmw6-c2p9
- https://nvd.nist.gov/vuln/detail/CVE-2019-10751
- https://github.com/advisories/GHSA-xjjg-vmw6-c2p9
- https://github.com/jakubroztocil/httpie
- https://github.com/jakubroztocil/httpie/releases/tag/1.0.3
- https://github.com/pypa/advisory-database/tree/main/vulns/httpie/PYSEC-2019-23.yaml
- https://lists.debian.org/debian-lts-announce/2019/09/msg00031.html
- https://snyk.io/vuln/SNYK-PYTHON-HTTPIE-460107
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00022.html
CVE-2019-10751 · published · modified · JSON