PyPI/python-cjson CVE-2009-4924: unknown, EPSS 1.35%
Dan Pascu python-cjson 1.0.5 does not properly handle a ['/'] argument to cjson.encode, which makes it easier for remote attackers to conduct certain cross-site scripting (XSS) attacks involving Firef
Action: Upgrade python-cjson to 1.1.0 or later.
pip install python-cjson==1.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.1.0 | - |
Fixed versions
| 1.1.0 |
Sources
- osv: PYSEC-2010-26
- http://t3.dotgnu.info/blog/insecurity/quotes-dont-help.html
- http://pypi.python.org/pypi/python-cjson/
- https://github.com/advisories/GHSA-95jp-77w6-qj52
CVE-2009-4924 · published · modified · JSON