PyPI/python-cjson CVE-2010-1666: unknown, EPSS 1.67%
Buffer overflow in Dan Pascu python-cjson 1.0.5, when UCS-4 encoding is enabled, allows context-dependent attackers to cause a denial of service (application crash) or possibly have unspecified other
Action: Upgrade python-cjson to 1.1.0 or later.
pip install python-cjson==1.1.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.1.0 | - |
Fixed versions
| 1.1.0 |
Sources
- osv: PYSEC-2010-30
- http://secunia.com/advisories/40335
- https://bugs.launchpad.net/ubuntu/+source/python-cjson/+bug/585274
- http://www.vupen.com/english/advisories/2010/1774
- http://www.debian.org/security/2010/dsa-2068
- http://secunia.com/advisories/40500
- https://github.com/advisories/GHSA-cqmh-mpx2-g633
CVE-2010-1666 · published · modified · JSON