PyPI/celery CVE-2011-4356: unknown, EPSS 0.33%
Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryd_detach, c
Action: Upgrade celery to 2.2.8 or later.
pip install celery==2.2.8pip install celery==2.3.4pip install celery==2.4.4Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.1 | 2.2.8 | - |
| 2.3 | 2.3.4 | - |
| 2.4 | 2.4.4 | - |
Fixed versions
| 2.2.8 | 2.3.4 | 2.4.4 |
Sources
- osv: PYSEC-2011-17
- https://github.com/ask/celery/blob/master/docs/sec/CELERYSA-0001.txt
- https://github.com/ask/celery/pull/544
- http://secunia.com/advisories/46973
- http://www.securityfocus.com/bid/50825
- https://github.com/advisories/GHSA-rpc6-h455-3rx5
CVE-2011-4356 · published · modified · JSON