tocsin

PyPI/apache-libcloud CVE-2010-4340: unknown, EPSS 1.39%

libcloud before 0.4.1 does not verify SSL certificates for HTTPS connections, which allows remote attackers to spoof certificates and bypass intended access restrictions via a man-in-the-middle (MITM)

Action: Upgrade apache-libcloud to 0.4.2 or later.

pip install apache-libcloud==0.4.2

Affected

introducedfixedlast affected
00.4.2-

Fixed versions

0.4.2

Sources

CVE-2010-4340 · published · modified · JSON