PyPI/django CVE-2011-4140: unknown, EPSS 1.09%
The CSRF protection mechanism in Django through 1.2.7 and 1.3.x through 1.3.1 does not properly handle web-server configurations supporting arbitrary HTTP Host headers, which allows remote attackers t
Action: Upgrade django to 1.2.7 or later.
pip install django==1.2.7pip install django==1.3.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.2.7 | - |
| 1.3 | 1.3.1 | - |
Fixed versions
| 1.2.7 | 1.3.1 |
Sources
- osv: PYSEC-2011-5
- https://bugzilla.redhat.com/show_bug.cgi?id=737366
- http://openwall.com/lists/oss-security/2011/09/11/1
- https://www.djangoproject.com/weblog/2011/sep/09/
- http://openwall.com/lists/oss-security/2011/09/13/2
- https://www.djangoproject.com/weblog/2011/sep/10/127/
- http://secunia.com/advisories/46614
- http://www.debian.org/security/2011/dsa-2332
- https://hermes.opensuse.org/messages/14700881
- https://github.com/advisories/GHSA-h95j-h2rv-qrg4
CVE-2011-4140 · published · modified · JSON