tocsin

PyPI/sqlalchemy CVE-2012-0805: unknown, EPSS 2.85%

Multiple SQL injection vulnerabilities in SQLAlchemy before 0.7.0b4, as used in Keystone, allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset keyword to the select

Action: Upgrade sqlalchemy to 0.7.0 or later.

pip install sqlalchemy==0.7.0

Affected

introducedfixedlast affected
00.7.0-

Fixed versions

0.7.0

Sources

CVE-2012-0805 · published · modified · JSON