PyPI/zope2 CVE-2012-6661: unknown, EPSS 2.38%
Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via u
Action: Upgrade zope2 to 2.13.19 or later.
pip install zope2==2.13.19Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.13.19 | - |
Fixed versions
| 2.13.19 |
Sources
- osv: PYSEC-2014-76
- https://plone.org/products/plone/security/advisories/20121106/24
- https://plone.org/products/plone-hotfix/releases/20121124
- https://bugs.launchpad.net/zope2/+bug/1071067
- http://www.openwall.com/lists/oss-security/2012/11/10/1
- https://github.com/plone/Products.CMFPlone/blob/4.2.3/docs/CHANGES.txt
- https://github.com/advisories/GHSA-48vv-2pmq-9fvv
CVE-2012-6661 · published · modified · JSON