tocsin

PyPI/oauth2 CVE-2013-4346: unknown, EPSS 2.43%

The Server.verify_request function in SimpleGeo python-oauth2 does not check the nonce, which allows remote attackers to perform replay attacks via a signed URL.

Action: Upgrade oauth2 to 1.9rc1 or later.

pip install oauth2==1.9rc1

Affected

introducedfixedlast affected
01.9rc1-

Fixed versions

1.9rc1

Sources

CVE-2013-4346 · published · modified · JSON