PyPI/ipython CVE-2015-6938: unknown, EPSS 2.79%
Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbit
Action: Upgrade ipython to 3.2.2 or later.
pip install ipython==3.2.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.2.2 | - |
Fixed versions
| 3.2.2 |
Sources
- osv: PYSEC-2015-24
- http://seclists.org/oss-sec/2015/q3/474
- https://github.com/jupyter/notebook/commit/35f32dd2da804d108a3a3585b69ec3295b2677ed
- http://seclists.org/oss-sec/2015/q3/544
- https://github.com/ipython/ipython/commit/3ab41641cf6fce3860c73d5cf4645aa12e1e5892
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/166471.html
- https://github.com/jupyter/notebook/commit/dd9876381f0ef09873d8c5f6f2063269172331e3
- https://bugzilla.redhat.com/show_bug.cgi?id=1259405
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/166460.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-September/167670.html
- http://lists.opensuse.org/opensuse-updates/2015-10/msg00016.html
- https://github.com/advisories/GHSA-4vwq-x64q-j4cj
CVE-2015-6938 · published · modified · JSON