PyPI/django CVE-2015-0219: unknown, EPSS 6.97%
Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header,
Action: Upgrade django to 1.4.18 or later.
pip install django==1.4.18pip install django==1.6.10pip install django==1.7.3Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.4.18 | - |
| 1.5 | 1.6.10 | - |
| 1.7 | 1.7.3 | - |
Fixed versions
| 1.4.18 | 1.6.10 | 1.7.3 |
Sources
- osv: PYSEC-2015-4
- http://secunia.com/advisories/62285
- https://www.djangoproject.com/weblog/2015/jan/13/security/
- http://secunia.com/advisories/62309
- http://www.ubuntu.com/usn/USN-2469-1
- http://secunia.com/advisories/62718
- http://advisories.mageia.org/MGASA-2015-0026.html
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:036
- http://www.mandriva.com/security/advisories?name=MDVSA-2015:109
- http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148485.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148696.html
- http://lists.fedoraproject.org/pipermail/package-announce/2015-January/148608.html
- http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html
- https://github.com/advisories/GHSA-7qfw-j7hp-v45g
CVE-2015-0219 · published · modified · JSON