PyPI/ansible CVE-2016-3096: unknown, EPSS 0.47%
The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /o
Action: Upgrade ansible to 2.0.2.0 or later.
pip install ansible==2.0.2.0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.0.2.0 | - |
Fixed versions
| 2.0.2.0 |
Sources
- osv: PYSEC-2016-1
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183103.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1322925
- https://github.com/ansible/ansible-modules-extras/pull/1941/commits/8c6fe646ee79f5e55361b885b7efed5bec72d4a4
- https://github.com/ansible/ansible/blob/v2.0.2.0-1/CHANGELOG.md#202-over-the-hills-and-far-away
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183274.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-May/184175.html
- https://github.com/ansible/ansible-modules-extras/pull/1941
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183132.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/183252.html
- https://github.com/ansible/ansible/blob/v1.9.6-1/CHANGELOG.md#196-dancing-in-the-street---tbd
- https://security.gentoo.org/glsa/201607-14
- https://groups.google.com/forum/#!topic/ansible-announce/tqiZbcWxYig
- https://groups.google.com/forum/#!topic/ansible-announce/E80HLZilTU0
- https://github.com/advisories/GHSA-rh6x-qvg7-rrmj
CVE-2016-3096 · published · modified · JSON